Potential issue for Veeam users

Incident Report for Impossible Cloud

Resolved

The issue has been resolved.
Posted Jun 24, 2025 - 15:27 CEST

Investigating

We are currently investigating an issue affecting Veeam users.
Posted Jun 24, 2025 - 11:53 CEST
This incident affected: S3 API eu-central-2, S3 API eu-west-1, and S3 API eu-east-1.