We experience a partial outage for our endpoint eu-west-1.

Incident Report for Impossible Cloud

Resolved

The endpoint is now fully available again.
Posted May 12, 2025 - 18:43 CEST

Investigating

The endpoint could experience availability problems. We have identified the issue and are on it to solve the problem as soon as possible!
Posted May 12, 2025 - 18:38 CEST
This incident affected: S3 API eu-west-1.