we regret to inform you that the scheduled maintenance has been postponed due to a hardware shipping delay from one of our hardware providers. We’re working to reschedule as soon as possible and will keep you updated.
Thank you for your understanding.
Posted Jun 02, 2025 - 08:54 CEST
Scheduled
Dear customers,
one of our hardware providers will be performing scheduled maintenance in one of our core datacenters in our eu-central-2 region as part of ongoing efforts to improve storage performance and reliability.
During this time, the endpoint may experience increased latency. We don't expect downtime but cannot rule it out. We will work to complete this maintenance as quickly and safely as possible.
We apologise for any inconvenience this may cause and thank you for your understanding and continued support.
– The Engineering Team
Posted May 30, 2025 - 14:23 CEST
This scheduled maintenance affected: S3 API eu-central-2.