Performance degradation and intermittent failures

Incident Report for Impossible Cloud

Resolved

The issue is resolved and we will monitor the situation closely.
Posted Jun 04, 2025 - 04:26 CEST

Update

We are continuing to work on a fix for this issue.
Posted Jun 04, 2025 - 02:30 CEST

Identified

We have identified a networking issue affecting the eu-central-2 region and we are working on a fix.
Posted Jun 04, 2025 - 02:08 CEST
This incident affected: S3 API eu-central-2.