We are experiencing an outage in eu-central-2

Major incident S3 API eu-central-2
2026-09-09 20:07 CEST · 33 minutes

Updates

Resolved

Issue has been identified and resolved.

September 9, 2026 · 20:41 CEST
Issue

We are currently experiencing an outage in eu-central-2 and are investigating.

September 9, 2026 · 20:07 CEST

← Back