We are experiencing Occasional Elevated Error Rates

Minor incident S3 API eu-north-1 S3 API eu-east-1
2026-07-10 20:14 CEST · 2 days, 17 hours, 10 minutes

Updates

Resolved

Dear customers,

the issue resulting in occasional elevated error rates on our S3 endpoint has now been resolved. Service reliability has returned to normal levels.

We’ve implemented corrective actions and are monitoring the system to ensure stability.

Thank you for your understanding, and we appreciate your continued trust.

July 13, 2026 · 13:24 CEST
Issue

Dear customers,

We are currently monitoring an issue affecting our S3 endpoint that may occasionally cause elevated error rates when accessing, uploading, or retrieving data. These occurrences are intermittent and do not represent a full service outage.

Our engineering team is actively investigating the underlying cause and working toward a permanent fix. In the meantime, we are closely monitoring the situation to minimize any impact on customers.

We apologize for any inconvenience and appreciate your patience while we resolve this.

July 10, 2026 · 20:14 CEST

← Back