We are experiencing a global outage of our Impossible Cloud Storage Console

Minor incident Impossible Cloud Storage Console
2026-04-22 20:43 CEST · 10 minutes

Updates

Resolved

Dear customers,

the issue has been resolved. Access to the service has been fully restored, and all operations are functioning normally.

We are now continuing to monitor the system closely to ensure continued stability.

We sincerely appreciate your patience during this disruption and apologize for any inconvenience caused.

April 22, 2026 · 20:53 CEST
Issue

Dear customers,

we are currently experiencing outage of our Impossible Cloud Storage Console. Customers may not be able to log in through the web interface at this time.

Please note: This incident affects the management interface only; direct S3 API access remains unaffected unless otherwise stated.

Our engineering team is actively investigating the root cause and working to restore console functionality as quickly as possible. This issue is being treated as a critical priority.

We sincerely apologize for the disruption and appreciate your patience while we resolve the issue.

April 22, 2026 · 20:43 CEST

← Back