S3 Endpoint experiencing occasional Performance Degradations during peak-hours
Minor incident
S3 API eu-central-2
2026-02-27 15:00 CET
· 2 weeks, 5 days, 20 hours, 10 minutes
Updates
Resolved
March 19, 2026 · 11:09 CET
Dear customers,
we have resolved the issue causing Performance Degradations during peak-hours in our eu-central-2 region. After one night of observing the performance, we let you know that the service reliability has returned to normal levels, also in peak-hours.
Thank you for your understanding, and we appreciate your continued trust.
Issue
March 2, 2026 · 16:36 CET
Dear customers,
some users may experience slower response times or intermittent errors during peak-hours at night using our S3 API in eu-central-2. While the system remains generally operational, these symptoms may impact reliability for certain operations. We are working on it and try to resolve it as soon as possible.
Thank you for your patience and understanding!
← Back
Impossible Cloud Status