ICMC experiences problems
Minor incident
Impossible Cloud Management Console
2025-10-28 16:43 CET
· 2 hours, 23 minutes
Updates
Resolved
October 28, 2025 · 19:06 CET
Dear customers,
the issue affecting our Impossible Cloud Management Console has now been resolved. Service reliability has returned to normal levels.
Thank you for your understanding, and we appreciate your continued trust.
Issue
October 28, 2025 · 16:43 CET
Dear customers,
we are currently investigating an issue causing problems with the use of our Impossible Cloud Management Console.
Some users may experience errors when accessing the service, while the system remains generally operational.
Our team is actively looking into the cause and taking steps to mitigate the issue. We will resolve the issue as quickly as possible.
Thank you for your patience and understanding.
← Back
Impossible Cloud Status